Delayed checklist submissions

Incident Report for Mobaro

Monitoring

We've identified the issue. Performance is returning to normal.
Posted Jun 05, 2025 - 17:13 CEST

Investigating

We are currently resulting in submitted checklists taking a longer time to process. This means that dashboards and other features may take slightly longer to react to otherwise completed and submitted checklists.

We are currently investigating the issue and will keep you updated. We apologize for the inconvenience.
Posted Jun 05, 2025 - 16:52 CEST
This incident affects: Backend Application.